Web Analytics Data Delay

Incident Report for Triple Whale

Resolved

This incident has been resolved.
Posted May 21, 2025 - 06:08 UTC

Investigating

We’re aware that some accounts may be experiencing delays in Web Analytics data on the Summary Page. Our team is actively investigating and working to resolve the issue.
Posted May 21, 2025 - 02:07 UTC
This incident affected: Summary.