Total Impact Slow to Load
Incident Report for Triple Whale
Resolved
This incident has been resolved.
Posted Oct 30, 2024 - 01:51 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 30, 2024 - 01:47 UTC
Investigating
Total Impact section on the Pixel page is currently loading slower than expected. Our team is aware of the issue, and we're actively investigating the issue. You can expect improvements shortly, and we'll update you once everything is back to normal.
Posted Oct 30, 2024 - 01:31 UTC
This incident affected: Pixel and Attribution.