Facebook ads data delay
Incident Report for Triple Whale
Resolved
The issue has been resolved.
Posted Jan 18, 2025 - 02:44 UTC
Identified
Facebooks ads data is currently delayed. The team is aware of the issue and working to implement a fix.
Posted Jan 18, 2025 - 01:54 UTC
This incident affected: Pixel and Attribution.