Triple Whale app is unavailable

Incident Report for Triple Whale

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 22:39 UTC

Update

Heads up that Triple Whale is down due to the Google Cloud outage. We'll update you as soon as things are back up and running.
Posted Jun 12, 2025 - 18:27 UTC

Identified

app.triplewhale.com is unavailable due to an outage with a third party service provider.
Posted Jun 12, 2025 - 18:12 UTC
This incident affected: All App Systems.