Pixel Data is delayed

Incident Report for Triple Whale

Resolved

This incident has been resolved.
Posted Jul 09, 2025 - 12:29 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 09, 2025 - 12:28 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 09, 2025 - 03:29 UTC

Investigating

⚠️ Heads up: Pixel Attribution data is currently delayed by approximately 2 hours. Our team is aware and working to resolve it as quickly as possible.
Posted Jul 09, 2025 - 02:11 UTC
This incident affected: Triple Pixel (Attribution, CDP).