Meta Data Delay

Incident Report for Triple Whale

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 23:00 UTC

Identified

Meta has confirmed an issue on their side affecting the Insights API, which is causing delays in Meta spend data being returned to Triple Whale. Other Meta data services have remained operational.

We are beginning to see data fetching recover, although responses are still intermittent as Meta works through the issue. Our team is continuing to monitor recovery and will provide updates as data flow returns to normal.
Posted Sep 01, 2026 - 18:14 UTC
This incident affected: All App Systems.